THE PROFESSIONAL DESKTOP
PUBLISHER

Tutorial
Contents

Tutorial .......................................................... 1
T.1 The Finished Product ......................................... 2
T.2 Loading Ovation Pro ........................................... 4
T.3 Creating the Document ....................................... 5
T.4 Interface Familiarisation ..................................... 6
T.5 The Grid ....................................................... 7
T.6 Frames .......................................................... 8
T.7 Saving and Autosaving ....................................... 9
T.8 Quitting Ovation Pro and Reloading Documents ........ 10
T.9 Entering and Editing Text ................................... 11
T.10 Importing Text ................................................ 12
T.11 Selecting Text ................................................ 13
T.12 Adding Local Effects ....................................... 14
T.13 Adding Defined Styles ..................................... 15
T.14 Editing Existing Defined Styles ......................... 16
T.15 Rotating and Moving Frames ............................. 17
T.16 Frame Borders and Drop Shadows ..................... 18
T.17 Drag and Drop ............................................... 19
T.18 The Clipboard ............................................... 20
T.19 The Character Selector ................................... 21
T.20 Grouping Frames ........................................... 22
T.21 Importing Pictures ......................................... 23
T.22 Zoom ......................................................... 24
T.23 Picture Manipulation ...................................... 25
T.24 Undo and Redo .............................................. 26
T.25 Spelling Checker ........................................... 27
T.26 Printing ....................................................... 28

Keyboard short-cuts ............................................ 29
*Ovation Pro* was first released in 1996 by Beebug Ltd. as version 2.24.
The original manual and tutorial were written by John Wallace, Software Manager of Beebug Ltd.
The program itself was written by David Pilling.
The present templates were designed by John Ferguson.
This revised tutorial was written by Jan van Vredenburch.
The author is grateful for comments from many users of *Ovation Pro.*
Tutorial

The tutorial provides a series of lessons on how to use Ovation Pro. The lessons are a series of steps that lead you through the production of a simple document. The lessons demonstrate some of the basic features of the software and how you can best use them in creating documents of your own. Files are supplied that show the sample document at key stages of its development so you can start the tutorial at any of these stages.

Menus

Menu options are shown in bold type:

The Misc Macros dialogue box allows macros to be created and edited.

The example above means choose the Macros option on the Misc menu from the main menu of an Ovation Pro document. At times the menu option will start with Menu .

To ease finding certain options while reading this manual the menu option is stated on a row of its own under Headings, Sub-headings and so on.

Many options can be selected directly by pressing a combination of keys on the keyboard. These short cuts are not mentioned in this Tutorial.

Some menus are context dependent. So for example if you have a picture selected you will not find Text on the main menu.

This Manual when reading from screen

If possible use a 256 colour or greater mode when reading this manual on screen.

The pictures in this manual may differ slightly from what you see on screen. In general MS Sans Serif is used as desktop font and screen shots have been taken on Windows NT to make things easier to see in print. The pictures also reflect the windows as used in Ovation Pro version 2.75. But do bear in mind that because of constant software development, this manual has not always been able to keep up.

Finally this document is not only a Tutorial for you to learn how to use Ovation Pro. That is a first step to master this extremely versatile program. But by investigating how this Tutorial itself was written you can discover much more. How it was written, how styles and effects were used, how certain frames were grouped.

One example: the vertical bar in the left column is grouped with the text in a separate text frame. If you ungroup this frame, include it in the main text and then move it, the bar will not maintain its position to the text.

And investigate how the last line on page 15 was created.

Do all your experiments on a copy.
T.1 The Finished Product

The document that this tutorial produces is shown below (figs. 1 and 2). It is a two page document with two columns, imported text and pictures and a rotated text frame.

Internet Pro

In this first issue of Internet Pro we will be examining the World Wide Web, what it is and how it works.

What is the World Wide Web?

The World Wide Web (WWW or W3) although considered by many to be the Internet, is in fact just a tool for accessing the Internet. This misconception can be traced to the fact that when the Internet is subjected to investigation by television, you are shown a computer connected to the Internet via the WWW. You see lots of graphics and a nice user interface where you point and click with your mouse to navigate your way around. I suspect that in the future this will be the way of things, that all of the complexity of the Internet will be packaged up in icons and buttons, but for now the WWW is just part of the Internet as you will have seen from the previous chapters.

One of the main attractions of the WWW is its friendly user interface. No UNIX commands. No command line prompts. Once you have accessed a WWW site you are in point and click heaven. Each site that you visit is linked to many other sites. A simple click of the mouse allows you to access those sites. In this way information about a particular subject can be stored on many different systems around the world, but accessed from one single WWW site.

Hyper HyperText

The WWW is a hypertext system. If you have used other hypertext help systems on an Acorn or other computer you will find the WWW very easy to use. A page of hypertext contains links within it. On a WWW page these can be within the text, a graphic, or associated with an icon. Textual links are usually in a different colour or underlined. Graphical links are just the pictures or icons that are displayed or ‘hot’ areas within the graphic, so that one picture can have several links associated with it. Browsers will often display the address of the page that will be accessed, so that you can determine which areas of a graphic are ‘hot’ or which are not. Generally pages that contain graphical links also have equivalent textual links, allowing users with text based WWW browsers access the same facilities as those with graphical browsers.

"Once you have accessed a WWW site you are in point and click heaven."

WWW pages are created using a special programming language called HTML - HyperText Markup Language. Each page is defined by a series of commands that are interpreted by your browser to build the page. It is this language that enables the hypertext links, graphics, sound and moving images to be embedded within the page.

What the URL is going on?

To access a WWW site you need to know its address. WWW site addresses take the form of a URL (uniform or universal resource locator). These are not of the same form as the domain names we use for FTP or email, but will rather contain them. For
example my Internet provider has the URL of:

http://www.demon.co.uk/

The bit before the forward slashes defines what transfer protocol will be used to access the site. HTTP stands for HyperText Transfer Protocol. This is the basic protocol that allows WWW pages to be shipped from the WWW site to your WWW browser. This first part can contain other protocol types such as FTP, but more of that later. The bit after the two forward slashes, and before the next forward slash, is the domain name of the WWW site. The last forward slash means display the home page (the first page you see when you access the WWW site) of this site. Most URL’s will have a pathname after this point that will define which page at the WWW site you want to access, for example:

http://info.ox.ac.uk/help/wwwfaq/index.html

This is the address for a WWW page at an Oxford University WWW site (info.ox.ac.uk) that displays the World Wide Web FAQ. The pathname help/wwwfaq/index.html is the page itself. This is a good page to look at before starting on your WWW exploits as it provides a lot of useful information about the WWW.

**Browsing the Web**

Before you can access the WWW you need a web browser. These come in two basic forms: textual and graphical. Textual browsers will only display text, whereas graphical browsers will display both text and graphics. Whilst graphical browsers are the way to go for accessing the WWW, you do have other options: you can access the web via a telnet session and even by email. To use a telnet session, telnet to:

nxoc01.cern.ch

When connected you will be prompted to select various options by typing in the numbers associated with them. These options reflect the hypertext links that would be displayed by a WWW browser.

To access the WWW by email, send an email message to webmail@curia.ucc.ie containing the following:

GO http://www.cern.net/gnrf/www.html

This will return an HTML file, along with a UUencoded version of it in text, giving more information about the WWW and how to access it. You will require an application to decode the UUencoded file.

**One stop internet access**

Using a fully-fledged WWW browser will allow you to access FTP, Gopher, WAIS, Telnet, Usenet news and email all via the same interface. Whilst this has the advantage that you only need to learn how to use your WWW browser, its disadvantage is that the WWW is notoriously slow to use.

**Speeding up the Web**

One of the main ways to increase the speed of accessing WWW pages when using a graphical web browser, is to find the option to turn off the graphics display. This is not as stupid as it sounds because, once you reach a page whose graphics you might want to see, you can turn the graphics option back on, and reload the page. The time taken in downloading all the previous pages as text will be more than made up for in reloading the page you want and seeing it in all its glory.

Most browsers offer the facility to cache pages. This involves keeping a copy of the page on disc so that if you want to backtrack to that page you can load it from your hard disc rather than downloading the page once again. This is considerably quicker and your browser will be able to store several previous pages.

When you find a page that interests you and you think you are likely to return to it, you can add it to a hotlist of WWW pages. A hotlist is just a list of URL’s that your browser will maintain between your sessions on the WWW, so that you can return to the page with a single click on the hotlist entry.

Finally, you can make use of proxy WWW servers. These are machines through which you can access the WWW. They store recent copies of very popular WWW pages. When you request that page via the proxy server, it will send you its copy of the page instead of sending your request on to the particular site in question. This can speed up access to popular sites enormously, but as the load on the proxy server increases, its response time will fall off, so the advantage you gain can be variable.
T.2 Loading Ovation Pro

To load *Ovation Pro* double-click on its short cut on the desktop (*fig. 4*) (if you have opted to have one) or alternatively find it on the Windows start menu usually under Programs->DavidPilling. After a few seconds an Ovation Pro window will appear.
T.3 Creating the Document

Each time you start *Ovation Pro* a new document is created. However the document that this tutorial shows you how to create has two columns. It is possible to modify the number of columns a document has after it has been created, but it is much better to start off with the correct definition. To create the basic two column document perform the following:

1. Choose the **New** option on the File menu to open the **New document** dialogue box (*fig. 4*).
2. Click once on the up adjuster arrow to the right of the **Columns** option.
3. All the other options should remain unchanged. Click on the **OK** button and the empty two column document will be created.

The result of your labours should be identical to the document T03.

**Additional information**

You can experiment further by creating documents of different sizes and orientations. Clicking on the menu icon (*fig. 4a*) to the right of the **Page** option in the **New document** dialogue box will give you various default paper sizes to choose from and clicking on the **Sideways** option will allow you to create landscape documents.

Landscape means that the page is wider than high, whilst Portrait refers to a page which is higher than wide.
T.4 Interface Familiarisation

The Button Bar
Running along the top of the document window below the title bar is the button bar. This is a series of buttons that allow quick and easy access to frequently used facilities such as saving, printing, cut and paste etc. If you cannot see its entire length it will scroll when you move the pointer over either end.

The Toolbox
The toolbox runs down the left-hand side of the document window by default. The tools on it provide functions such as drawing and editing frames and lines, document zoom and object rotation.

The Info Palette
By default the info palette runs along the bottom of the document window. It is context sensitive. This means that its contents change depending on what operation you are performing in the document. Various functions of the info palette will be explained in the following pages.

The Default Master Frame and Caret
The default master frame is present by default in all new documents. The default master frame contains the caret. This is the red symbol which shows where text will be entered. Clicking in an empty frame will place the caret in it. Frames are used to contain text or pictures so that they can be positioned easily anywhere on a page.
The grid facility allows users to re-size and move objects around accurately within documents. We need to turn the grid lock on and change the spacing between the points on the grid, so:

1. Click Menu over the document window and choose the View→Grid option (i.e. choose the Grid option from the View submenu). This opens the Grid dialogue box (fig. 6).

2. Choose the Show grid option.

3. Choose the Lock grid option.

4. Change the Sub divisions value to 5. Click on OK to set these options.

**Additional information**

The grid can also be controlled from the button bar. The Grid button switches the grid and grid lock on and off (fig. 7).
T.6 Frames

Across the top of our document is the title (fig. 1), which is enclosed within a frame so that it can go across the two columns. To create the frame follow these steps:

1. Choose the Frame tool and ensure that the Rectangle tool is also selected on the toolbox (figs. 7 & 8). The pointer will change to a crosshair when the Frame tool is selected and the pointer is over the document.

2. Drag with from the top left-hand corner of the default frame across to the right. You will see a grey outline being drawn as you do this.

3. Keep dragging until you reach the right-hand side of the default frame. The window will scroll if you have to move the pointer near the edge of the window. The pointer will snap to the right-hand edge of the default master frame once the pointer gets near it.

4. Continue the drag downwards and look at the value for the height of the frame as displayed in the info palette. This is shown in the option labelled H. When this value reaches 38mm release the mouse button and the frame will be drawn.

5. The values for the frame as shown in the info palette should be X 10mm Y 10mm W 190mm and H 38mm (fig. 9). If the values are different you can enter the values into the respective icons in the info palette pressing Return after each and the frame will be updated. Use the up and down cursor keys to move between the options.

6. Alternatively, you can drag the handles of the frame to re-size it. Handles on the sides of frames re-size them horizontally or vertically. Handles on the corners of frames re-size them horizontally and vertically.

Additional information

Select a frame by clicking over it.

If you create a frame you subsequently want to delete, select the frame and click on the Delete object button (fig. 10) or choose the Edit->Delete Text frame option.

Pictures can only be imported into empty frames. You can change between text and a picture by deleting all the text or the picture.
T.7 Saving and AutoSaving

Menu: File: Save

Before we continue it is a good idea to save our document. An even better idea is to get into the habit of using Ovation Pro's auto-save facility. This will automatically save your document at regular intervals so that if some disaster occurs you do not lose all of your work. To save your document for the first time do the following:

1. Click on the Save as button on the button bar (fig. 11). This will open the Save as window (fig. 12).
2. Clear the contents of the writable icon and enter Tutorial.
3. Click on the Save button in the Save as window.

Having saved the document once you can save it subsequently by typing Ctrl S. Alternatively

1. Click on the Save as button on the button bar.
2. Click on the Save button or press Return.

The Save as dialogue can also be opened by choosing the File: Save As option.

AutoSaving

Menu: Misc: Preferences

To turn on auto-saving choose the Misc: Preferences option. This will open the Document preferences dialogue box (fig. 13). Choose the Auto save option from the General options (which are displayed by default) and click on OK. Now your document will be saved every ten minutes as long as it has been modified since it was last saved.

Fig. 11 - The Save as button

Fig. 12 - The Save as dialogue box

Fig. 13 - The Document preferences dialogue box
T.8 Quitting Ovation Pro and Reloading Documents

At some stage you may want to stop working through this tutorial and do something else. To quit *Ovation Pro* do this:

1. Click File on the menu bar icon and choose **Exit** from the file menu (**fig. 14**). Or press Alt F4

If your document has been modified (it has an asterisk after the document name in the title bar), but not saved, you will be warned that this is so and given the option to discard the document or cancel the **Quit** operation (**fig. 15**). If you cancel the **Quit** operation you can save the document and then quit *Ovation Pro*. Choosing **Discard** will cause the modified document to be discarded and *Ovation Pro* to quit.

To reload a document:

1. Double-click over its icon in a Windows explorer window. This will load the document into *Ovation Pro* if it is running. If *Ovation Pro* is not loaded it will be run and then the document will be loaded.
T.9 Entering and Editing Text

Text is entered at the caret. There are several pieces of text to be entered during the course of the tutorial, but we will concentrate on the first sentence of the main body of text. Before entering the text make sure that the caret is present and positioned at the correct place. This is in the first column below the frame you drew in lesson T.6.

1. If the caret is not present it is likely that the Select tool is not chosen. Choose the Select tool and left click where you want the caret to appear.

2. Enter the following text:
   In this issue of Internet Pro we will be examining the World Wide Web, what it is and how it works.

3. Press Return twice after the text.

Additional information

Notice that the text automatically word wraps, that is it moves from the first line onto the second without you having to press Return.

If you make any errors while typing in this text you can use the following keypresses to correct them:

Delete delete the character before the caret
Backspace delete the character after the caret
↑ move caret up one line
↓ move caret down one line
← move caret left one character
→ move caret right one character
Ctrl → move caret to the next word
Ctrl ← move to the beginning of present word or to the previous word
End move to the end of the current line
Home move to the beginning of the current line
Ctrl Home move caret to beginning of story
Ctrl End move caret to end of story
Shift Ctrl↑ move text down one line
Shift Ctrl↓ move text up one line
T.10 Importing Text

The main body of text follows after the text you have just entered. This can be imported from a file provided. To do this perform the following:

1. Drag the text file `MainText.txt` from the `Tutorials\Text` directory into the window. This directory is the same one as this document is contained in.

2. Stop the drag when the pointer is below the text you entered in lesson T.9. The text file should be imported after the two Return characters.

Additional information

The text will flow into the two columns and onto a second page that is created automatically. The text will not fill the second page, this leaves us room to add other frames containing text and pictures. Use the vertical scroll bar to examine both pages in the document.

Note that if a text file contains single or double quotation marks they will be converted to fancy quotation marks when you import the file i.e. ‘’ pairs become ‘ ’ and " " pairs become “ ”. If this does not happen check the setting of the Text handling choices menu (Menu: Misc: Choices: Text: Smart quotes). The conversion will only be done if the "Smart quotes" option has been selected.
T.11 Selecting Text

Before you can manipulate text you need to be able to select areas of the text. In the next lesson you will need to select a word. Perform the following to enter the word and select it:

1. Click over the frame you drew in lesson T.6 to place the caret within it. Enter the word Internet.
2. Select the word by double-clicking over it.

Additional information

Selecting text by dragging:
You can also select an area of text by dragging. The area that is selected will start where you start the drag and end where you finish the drag. You can decrease or increase the selected area by clicking inside or outside it whilst holding down Shift.

Selecting text using multiple clicks:
- Double-click will select the current word and, if present, any following spaces.
- Triple-click will select the current line.
- Four clicks will select the current paragraph.
- Five clicks will select the entire story.

Note that you will need to keep the pointer relatively still and make the clicks in quick succession for this method to be successful.

Clearing the selection:
A single left click anywhere in the document will clear any selection. You can alternatively choose the Edit-Clear option.
T.12 Adding Local Effects

The text that you enter into Ovation Pro can have different fonts, sizes, styles (such as bold or italic) and colours. These attributes are called text effects. Effects can be applied at the caret or to a selected area of text. If an effect is applied at the caret any text that is subsequently typed will use that effect. If the caret is moved before any text is entered the effect will be forgotten. Effects are most commonly applied to selected areas of text.

We will now add a local effect to the word ‘Internet’ entered in lesson T.11. All we need to change is the size of the text:

1. Ensure the word is selected. If it isn’t, select it by double-clicking or dragging over it.
2. Click in the Size icon on the info palette (fig. 16).
3. Delete the number in the icon, enter 70 and press Return.

Additional information

Many of the effects available on the info palette may also be applied using submenus of the Text menu. The full range of effects are available from the Text→Modify text dialogue box. This dialogue box can also be opened by clicking on the Modify text button on the button bar (fig. 17).

You can experiment further with local effects. The easiest way to do this is to use the info palette (fig. 16). This allows you to quickly apply effects and to change the font, font size and format of the text. The text effect icons, in order, add the following effects: normal (no effects), bold, italic, underline, reversed, superscript and subscript. The text format icons, in order, add the following formats: left-justified, centred, right-justified and justified.

Fig. 16 - The info palette showing the effect options

Fig. 17 - The Modify text button
T.13 Adding Defined Styles

Menu→Style→Edit style

If you are going to use the same style more than once or twice in a document it is best to set up a defined style. This will allow you to apply the same style to many areas of text. It also has the benefit that if you subsequently want to change the style you only need to edit it and the changes will be made wherever the style is used throughout the document.

Defined styles can be created that apply to single words, a line, selected areas of text, or whole paragraphs. In our example we will create a defined style for the section headings in the main body of the text:

1. Choose the Style→Edit style option (fig. 18).
2. Click on the New button, enter Heading into the New style icon and click on OK.
3. Type Shift F1 to assign this keypress to the new style. You will see Shift+F1 appear in the Key icon.
4. Click on the Text... button. This shows all of the text effects that can be assigned to the style.
5. Click on the menu icon for the Font option and choose Arial from the menu.
6. Click on the menu icon for the Size option and choose 14pt from the menu.
7. Click in the H scale option, clear the current value and enter 80 and ensure that the option button is ticked.
8. Click on the Bold option button so it is ticked.
9. Click on OK to register all of these choices.
10. The Edit style dialogue shows a piece of text with the style you have defined applied to it and a summary of the style. Click on OK to create the new style.
11. Now place the caret in the first section heading: What is the World Wide Web? and press Shift F1 to apply the style. Note that you do not need to select the area for the style to be applied to because the style was created to apply to the whole paragraph (by default).
12. Repeat this procedure for all of the six section headings. Use the vertical scroll bar to move between the two pages.

Additional information

You will probably have noticed that when you were selecting options on the defined style dialogue boxes that each option had an icon to the left of it. This icon defines how the option will affect the text. A crossed icon means that this option will not have any effect, a ticked icon means that the option will take effect and a blank icon means that the option will be turned off if it is present.

You can experiment by creating other styles and applying them to various pieces of text. An obvious candidate for this are the lines of text that show the various Internet addresses e.g. http://www.demon.co.uk/. Try creating and applying a style of Courier New in 10pt text to these lines.

(Hint: the Style summary should show the following: Courier New+10pt )
T.14 Editing Existing Defined Styles

As was mentioned earlier one of the most powerful features of defined styles is that they can be amended and the changes will be made wherever that style is used. We need to alter the Bodytext style slightly; this is the style that is used by default for text. To do this, perform the following:

1. Choose the Style→Edit style option (fig. 18).
2. Ensure that the Bodytext style is selected in the scrollable pane at the top left of the dialogue box. If it isn't click over it to select it.
3. Click on the Format… button. This shows all of the format effects that can be assigned to the style.
4. Click on the menu icon to the right of the Alignment option.
5. Choose Justify from the menu.
6. Click on OK to confirm the choice.
7. Click on OK on the Edit style dialogue box to change the style. You will notice that all of the main text becomes justified i.e. the text is spaced so that the right edge aligns to the right margin.

Additional information

This tutorial uses many styles. And very few effects. Effects are present were another font is used (e.g. the arrow in "Menu→Style") and generally all text presented in italics.

![Fig. 18 - The Edit style dialogue box](image)
T.15 Rotating and Moving Frames

One of Ovation Pro's most powerful features is the ability to rotate text frames whilst leaving the text inside editable. This is how you create the rotated frame in the sample document:

1. Draw a frame near the top right-hand corner on the first page. It should have the following dimensions: W 38mm H 20mm, its X and Y values will depend on where it is drawn. Use the info palette to check the frames width and height.

2. Ensure the frame is selected, if it isn’t left click over it. Choose the Rotate tool (fig. 19). Click on the pre-defined 90° box on the info palette. Choose the Select tool.

3. To move the frame to its required position left click and hold down the mouse button. Still holding the button down drag the frame up into the title area and using the info palette position it at: X 179mm Y 47mm.

4. Left click in the frame so that it gets the caret and enter Issue One. The text will appear sideways (fig. 1).

5. Select the text, click on the Modify text button (fig. 17) to open the Modify text dialogue box and change its Font to Arial, its H Scale to 50%, its Size to 40pt (use the last option on the menu) and click on Bold. Click on OK.

6. Left click to clear the selection.

Additional information

To enter values other than one of the pre-defined settings when rotating click in the A option on the info palette, clear the current contents, enter the value you want and press Return.

You will notice that once the Rotate tool is selected a crosshair appears in the centre of the frame. This crosshair defines the centre of rotation that will be used when you rotate the frame. The crosshair can be dragged around so that the centre of rotation is altered. You can also select one of the pre-defined centres of rotation by clicking on one of the 9 boxes on the info palette.

Selected frames can also be rotated precisely using the option on the Modify text frame dialogue box available by choosing the Menu>Object>Modify option.

A frame can be moved immediately by holding down Ctrl and dragging with the right mouse button.
T.16 Frame Borders and Drop Shadows

Menu → Object → Border

Any rectangular frame can be given a border and a drop shadow. Irregular shaped frames can only have borders applied to them. A drop shadow is really only effective if the frame to which it is applied has a frame border or a fill colour. We will now apply a border and drop shadow to the frame we drew in lesson T.15:

1. Select the frame by clicking over it and click on the Border button on the button bar (fig. 20).
2. Choose the Border option, click on the menu icon to the right of the Width option and choose the Thin option.
3. Choose the Shadow option, click on the menu icon to the right of the Width option and choose the 1mm option.
4. Choose the shadow for the bottom right-hand corner of the frame (remember the frame is rotated). The four icons in the top right of the dialogue box are used to determine the position of the drop shadow. fig. 21 shows the dialogue box as it should be before you click on OK.

Additional information
You can experiment adding borders and drop shadows to the other frame on the page. You can choose different styles of border from the scrollable pane on the Border dialogue box.

![Fig. 20 - The Border button](image)

![Fig. 21 - The Frame border dialogue box](image)
T.17 Drag and Drop

Drag and drop allows you to move and copy selected objects, text and pictures inside and between documents. As an example of this we will select an area of text and copy it within our sample document:

1. Draw a frame near the bottom of the first column on the first page with these dimensions: X 10mm Y 238mm W 92mm H 22mm. Use the info palette to help you. If you need to move the frame left click and hold and then drag.

2. Select the following text:
   although considered by many to be the Internet, it is in fact just a tool for accessing the Internet.
   by dragging over it. You will find it in the third paragraph on the first page.

3. Hold down the Shift key and click and hold the left mouse button over the selected text. The pointer will change shape (fig. 22). Move the pointer over the frame drawn in point 1 and release the mouse button. The text will be copied into the frame. The window will scroll, if necessary, as you drag.

4. Select the copied text and make it italic, 14pt and centred either locally using the info palette (see lesson T.12) or by creating and applying a defined style (see lesson T.13). The Centre option can be assigned to a style using the same steps as were used in lesson T.14, but by choosing Centre instead of Justify.

Additional information

It is also possible to hold down the Alt and Shift keys and drag over the selected text to copy it somewhere else.

The action of drag and drop is different if you drag a selected piece of text without Shift held down. In this case the selected text is moved rather than copied. This facility allows you to move text across page boundaries.

The action of drag and drop is reversed if you are moving items between documents. If Shift is held down the selected text is moved to the other document. If Shift is not held down it is copied.

To see how this works create a frame with some text at the bottom of a page. Put the caret back in the main frame, and type Ctrl Return to add a new page. Now select the text in the frame on the previous page and then drag the text to the following page, once while holding down Shift (copies) and then without holding down Shift (moves). Now try the same with two Ovation Pro documents.

The same procedure applies for pictures or objects. But then one must hold down the Alt key as well.

Fig. 22 - The Drag and drop pointer
T.18 The Clipboard

Using drag and drop is not the only way to move items around and between documents. *Ovation Pro* also can use the Windows clipboard. You can cut or copy items onto the clipboard and then paste them back into any document.

1. Draw a frame near the top of the second column on the first page with these dimensions: X 108mm Y 62mm W 92mm H 18mm. Use the info palette to help you. If you need to move the frame left click and hold and then drag.

2. Select the following text:
   Once you have accessed a WWW site you are in point and click heaven. You will find the text in the fourth paragraph on the first page.

3. Copy the text onto the clipboard by clicking on the Copy button on the button bar (fig. 23).

4. Click in the frame you drew in point 1 to place the caret within it.

5. Paste the text into this frame by clicking on the Paste button on the button bar (fig. 24).

6. Select the text and make it italic, 14pt and centred either locally or by using the defined style if you created one in lesson T.17.

Additional information

*(Menu Edit........)*

**Cut, Copy** and **Paste** are also available from the **Edit** menu. You can also cut by using the Cut button (fig. 25).

The contents of the clipboard are not altered by pasting, so you can paste the same item a number of times, but only one item can be held on it at a time so the next thing that is cut or copied to the clipboard will overwrite the current contents. You can view the contents of the clipboard by clicking on the View clipboard button on the button bar (fig. 26).

You can experiment by creating a frame to cut or copy onto the clipboard and then pasting it back. Notice that when you choose to paste an object back into a document the pointer changes to a crosshair and clicking will mark the place where the top left-hand corner will be positioned.

Note that the **Cut, Copy** and **Paste** options are applicable to the current selection, whether it is text or an object.
T.19 The Character Selector

Ovation Pro has a built-in character selector. This allows you to select characters that are not easily accessible from the keyboard. We need to add fancy quotes around the text that we dragged and dropped in lesson T.17 and cut and pasted in lesson T.18 and prefix the first piece of text with an ellipsis (…). To do this:

1. Place the caret before the word although in the frame in the first column.
2. Press F11 to open the Characters dialogue box (fig. 27).
3. Move the pointer over the characters. The text icon at the top right pointer will change as the pointer moves over each character showing the keys to type for the character and its name.
4. Click over the opening smart double quote (0147) and then the ellipsis (0133). Close the Characters dialogue box.
5. Move the caret to the end of the text after Internet, reopen the Characters dialogue box and click over the closing smart double quote (0148). Close the Characters dialogue box.
6. Add smart double quotes to the text in the frame in the second column in the same way.

Additional information

The Characters dialogue box is also available by choosing the Misc\textsuperscript{\textregistered} Characters option.

Once you become familiar with the numbers for characters you can access them directly by holding down the Alt key and entering its number on the numeric keypad. The character will be inserted when you release the Alt key.
T.20 Grouping Frames

Menu › Object › Group or Menu › Object › Ungroup

Objects such as frames and diagrams can be grouped together. For our purposes the screenshot frame and its caption can be grouped. It is likely that when laying out a page, such as is used in our example, grouping the two frames together would be beneficial since they can then be treated as a single object. Perform the following steps to create and group the frames:

1. Draw a frame for the screenshot about half way down the second column on the first page with these dimensions: X 98mm Y 116mm W 102mm H 82mm. Use the info palette to help you. If you need to move the frame click and hold down the left button over the frame for a second and then drag.

2. Draw the frame for the caption below the first with these dimensions: X 98mm Y 198mm W 102mm H 8mm.

3. Ensure that one frame is selected and then click on the other whilst holding down Ctrl.

4. Group the frames by choosing the Object › Group option.

5. Click in the caption frame, notice that even though the frames are grouped the frame will still get the caret and text can be entered into the frame.

6. Enter the following text: Acorn Computer Group’s home page. Optionally use the character selector introduced in lesson T.19 to add a fancy apostrophe.

7. Make the text 10pt and italic using the info palette, see lesson T.12.

Additional information

Any number of frames or diagrams can be grouped together in this manner. To select each object click on it whilst holding down Control. To remove an object from the selection click on it whilst holding down Control.

If you quickly want to move two or more objects together you can do this by selecting them both and dragging over either of them. Selected objects can also be resized and rotated together. But doing this does not have the same effect as when resizing or rotating a grouped object.

A group of objects can be ungrouped by choosing the Object › Ungroup option.

Grouping and ungrouping can also be done with a key short-cut: Shift-Ctrl-K.
T.21 Importing Pictures

There are two pictures in the sample document. This is how to import them:

1. Draw a frame to the right of the word Internet in the title, the frame should have these dimensions: X 92mm Y 10mm W 86mm H 38mm. Check these in the info palette.

2. The pictures to import into these frames are in the Tutorial\Pictures directory. This directory will be in the same directory as the Ovation Pro application.

3. Drag the Draw file Pro from the Pictures directory into the frame drawn in point 1.

4. Drag the sprite file Screen from the same directory into the larger frame drawn in lesson T.20.
T.22 Zoom

Whilst working on documents it is often useful to zoom in on a particular area so that you can see it in more detail as you work on it. Alternatively you can zoom out so that you can see the whole document when trying to position objects on a page. Before we move on we need to zoom in on the ‘Pro’ picture:

1. Choose the Zoom tool (fig. 28).
2. Move the pointer over the ‘o’ in ‘Pro’ picture and click twice. This will zoom in on the ‘o’.

Additional information
Clicking when the Zoom tool is selected zooms in on the document as you can see, whilst right clicking zooms out. You will notice that the part of the document that is under the pointer when using zoom via this method stays under the pointer. You can also change the zoom via the info palette. When the Zoom tool is selected the info palette offers various preset zoom values and the option to set the zoom to a user defined value (fig. 29).

Other preset zoom values, so as to fit your screen mode, are available using the Zoom box button (fig. 28a).

Another way to double or halve the view quickly without needing to select the Zoom tool or to go by the menu is by holding down Alt Ctrl and then left clicking (zooms in) or right clicking (zooms out).

![The Zoom tool](image1)

![The Zoom button](image2)

![The info palette shown when the Zoom tool is selected](image3)
T.23 Picture Manipulation

Pictures can be manipulated within their frames. They can be moved, scaled, rotated, skewed and cropped. In our example we only need to scale one of the pictures slightly:

1. Ensure the Select tool is chosen. Double-click over the ‘Pro’ picture to select it. You will see a three-pronged tool appear (fig. 30).

2. Drag on the handle at the end of the horizontal line until the ‘o’ is close to the right-hand edge of the frame. The Aspect option in the info palette will show a value between 104 and 104.5.

3. Choose the Zoom tool (fig. 28). Click on the 100% option in the info palette.

Additional information

Dragging over the handle at the end of the vertical line will scale the picture vertically and dragging over the handle at the end of the diagonal line will scale the picture both horizontally and vertically. Whilst the picture is selected dragging over it with the left button will cause it to move. To rotate the picture choose the Rotate tool (fig. 19). Now dragging within the frame will rotate the picture. The crosshair can be moved to alter the centre of rotation. To crop the picture choose the Crop tool (fig. 31). Dragging over the picture will draw a rectangle, the area of the picture within this rectangle will be scaled to fill the frame once the drag is complete.

To skew the picture you must pass through the menu: Menu: Picture: Modify picture.

Selected pictures can be deselected by right clicking over them.

Fig. 30 - Selected ‘Pro’ graphic

Fig. 31 - The Crop tool
T.24 Undo and Redo

The ability to undo changes made to a document is invaluable. Once you start using *Ovation Pro* in earnest you will probably come to appreciate this facility more than any other. It also gives you the freedom to try changes in a document and then undo them if you do not like the result. For example:

1. Ensure the Select tool is chosen. Double-click over the ‘Pro’ picture to select it once again. Ensure the three-pronged tool appears.
2. Choose the Rotate tool (*fig. 19*).
3. Left drag within the frame to rotate the picture.
4. Now click on the Undo button on the button bar to undo the rotation (*fig. 32*). Choose the Select tool.

**Additional information**

You can generally always undo the last operation (you cannot undo things that change the documents view, such as turning on the grid) and several further operations as well. There are circumstances where an operation cannot be undone. If this is the case the **Undo** option on the **Edit** menu will be shaded.

**Redo** will redo the last undone operation. To Redo click on the Redo button on the button bar (*fig. 33*).

**Undo** and **Redo** options are also available from the **Edit** menu and by pressing Ctrl Z and Ctrl Y respectively.

---

**Fig. 32 - The Undo button**  **Fig. 33 - The Redo button**
Ovation Pro has an integrated spelling checker. The text we imported into our sample document has many words in it that are not in the dictionary, but it also has a spelling error. We will use the spelling checker to correct this error:

1. Left click in the main body of the text.
2. Click on the Check story button on the button bar (fig. 34).
3. Click on Ignore to ignore the first three words that are flagged as possible errors (Internet, WWW and W3).
4. The fourth error is “conected”. The spelling checker offers alternative words in the scrolling panel (fig. 35), click on connected and then on Replace. The incorrect word will be replaced and the next possible error flagged.
5. Continue clicking on Ignore until Ovation Pro reports that there are no more spelling errors.

Additional information
The spelling checker allows you to add words to the main dictionary or a user dictionary. If you were going to check lots of documents like the sample you would probably add the more common technical words to a user dictionary. It is also possible to check a single word by clicking on the Check word button (fig. 36). This will spellcheck the word at the caret.

The spelling checker facilities are also available from Misc Spellcheck menu options.
T.26 Printing

Menu : File : Print or Ctrl P

To print from Ovation Pro you must have a printer driver for your printer installed. To do this investigate Printers on the Settings submenu of the Windows Start menu. To print the two page sample document:

1. Click on the Print button on the button bar to display the Print dialogue box (fig. 36).
2. Click on the Print button.

If you find that the edges of the printout are missing perform the following:

1. Click on the Print button on the button bar to display the Print dialogue box (fig. 36).
2. Click on the Print setup option. This extends the dialogue box to give further options.
3. Click on the Fit option. This will scale the pages so that they fit within the printable area as specified by the printer driver.
4. Click on the Print button.

Additional information

You can alter the number of copies you print by altering the number in the Copies option. By choosing the Range option you can specify a range of page numbers to print in the writable icon to the right of the option. The menu icon to the right of the Format option gives you option to print in Pamphlet and Galley modes and several other modes. Pamphlet printing will automatically scale A4 pages down to A5 and print them in the correct order so that the resulting pages can be folded into a pamphlet. Galley printing will do the same, but it will output the pages in order. This option is useful for saving paper when doing draft printouts.

The Print dialogue box can also be opened by pressing the Ctrl P key or by choosing the File : Print option.

Fig. 36 - The Print button

![Print dialogue box]

Fig. 37 - The Print dialogue box
Keyboard short-cuts

**Function keys**

<table>
<thead>
<tr>
<th>Key</th>
<th>Key with Ctrl</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help</td>
</tr>
<tr>
<td>F2</td>
<td>(Not used)</td>
</tr>
<tr>
<td>F3</td>
<td>Find next</td>
</tr>
<tr>
<td>F4</td>
<td>Close document</td>
</tr>
<tr>
<td>F5</td>
<td></td>
</tr>
<tr>
<td>F6</td>
<td>Modify text/picture</td>
</tr>
<tr>
<td>F7</td>
<td>Modify object</td>
</tr>
<tr>
<td>F8</td>
<td></td>
</tr>
<tr>
<td>F9</td>
<td></td>
</tr>
<tr>
<td>F10</td>
<td></td>
</tr>
<tr>
<td>F11</td>
<td>Characters (see Misc menu)</td>
</tr>
<tr>
<td>F12</td>
<td>Single shift font change</td>
</tr>
</tbody>
</table>

**Keys with Ctrl & Ctrl Shift**

<table>
<thead>
<tr>
<th>Ctrl</th>
<th>Ctrl Shift</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Select All</td>
</tr>
<tr>
<td>B</td>
<td>Bold</td>
</tr>
<tr>
<td>C</td>
<td>Copy</td>
</tr>
<tr>
<td>D</td>
<td>Insert Date</td>
</tr>
<tr>
<td>E</td>
<td>Centre</td>
</tr>
<tr>
<td>F</td>
<td>Find/replace</td>
</tr>
<tr>
<td>G</td>
<td>Goto page</td>
</tr>
<tr>
<td>H</td>
<td>Object shape</td>
</tr>
<tr>
<td>I</td>
<td>Italic</td>
</tr>
<tr>
<td>J</td>
<td>Justify</td>
</tr>
<tr>
<td>K</td>
<td>Delete object (Kill)</td>
</tr>
<tr>
<td>L</td>
<td>Left align</td>
</tr>
<tr>
<td>M</td>
<td>Show/Hide Print Margin</td>
</tr>
<tr>
<td>N</td>
<td>New document</td>
</tr>
<tr>
<td>O</td>
<td>Open document</td>
</tr>
<tr>
<td>P</td>
<td>Print</td>
</tr>
<tr>
<td>Q</td>
<td>Remove styles</td>
</tr>
<tr>
<td>R</td>
<td>Right align</td>
</tr>
<tr>
<td>S</td>
<td>Save document</td>
</tr>
<tr>
<td>T</td>
<td>Open Thesaurus</td>
</tr>
<tr>
<td>U</td>
<td>Underline</td>
</tr>
<tr>
<td>V</td>
<td>Paste selection</td>
</tr>
<tr>
<td>W</td>
<td>Spellcheck Word</td>
</tr>
<tr>
<td>X</td>
<td>Cut selection</td>
</tr>
<tr>
<td>Y</td>
<td>Redo</td>
</tr>
<tr>
<td>Z</td>
<td>Undo</td>
</tr>
</tbody>
</table>

...
Keyboard short-cuts (cont'd)

**Keys with Ctrl & Ctrl Shift**

<table>
<thead>
<tr>
<th>Ctrl</th>
<th>Ctrl Shift</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ Subscript</td>
<td>Superscript</td>
</tr>
<tr>
<td>- Soft hyphen</td>
<td>Hard hyphen</td>
</tr>
<tr>
<td>1 100% zoom</td>
<td></td>
</tr>
<tr>
<td>2 200% zoom</td>
<td></td>
</tr>
<tr>
<td>3 150% zoom</td>
<td></td>
</tr>
<tr>
<td>4 400% zoom</td>
<td></td>
</tr>
<tr>
<td>5 50% zoom</td>
<td></td>
</tr>
<tr>
<td>6 Variable zoom</td>
<td></td>
</tr>
<tr>
<td>7 ...</td>
<td></td>
</tr>
<tr>
<td>8 ...</td>
<td></td>
</tr>
<tr>
<td>9 shift baseline down 1%</td>
<td>shift baseline down 5%</td>
</tr>
<tr>
<td>0 shift baseline up 1%</td>
<td>shift baseline up 5%</td>
</tr>
<tr>
<td>&lt; decrease fontsize by 1pt</td>
<td>decrease font size through range 8pt to 36pt</td>
</tr>
<tr>
<td>&gt; increase font size by 1pt</td>
<td>increase font size through range 8pt to 36pt</td>
</tr>
</tbody>
</table>